10月 20

Twitter社会論 ~新たなリアルタイム・ウェブの潮流 (新書y)いつからなのか明確に気付いてはいないのですが、この Weblog を運用しているサーバ(FreeBSD 8.1-STABLE)で TwiProwl 1.4.0 が動作しなくなってしまいました。iconv がないって怒られてしまっています。ruby-1.9.2.0,1 になってからかなぁ・・・

ports/lang/ruby19/ が、iconv.so をインストールしてくれないことが原因のようです。ports の不具合なのかなぁ?

で、考えていても仕方ないので、無理矢理 iconv.so をインストール。
ruby19 をインストールした状態で、

# cd /usr/ports/lang/ruty19/
# make
# cd work/iconv/
# ruby19 extconf.rb --with-iconv-include=/usr/local/include/ --ruby=/usr/local/bin/ruby19
# make
# /usr/bin/install -c -o root -g wheel -m 0755 iconv.so /usr/local/lib/ruby/1.9/i386-freebsd8

としました。
これで無事、iconv.so がインストールされ、TwiProwl も動作。
ports 自体をどう修正すればよいのかよくわからないので、こちらは放置。

関連記事

 
Posted: 10月 20日 2010 at 0:15 2,633 views   Tagged with:


にほんブログ村 PC家電ブログ Macへ にほんブログ村 野球ブログ 広島東洋カープへ にほんブログ村 写真ブログ デジタル一眼レフカメラへ 人気ブログランキングへ 広島ブログ


週刊 鉄道ペディア 国鉄JR篇 JTB Time Table MacPeople Software Design Hiroshima Athlete Magazine EIZOダイレクト フォトブック作成サービスcocoal(ココアル)
preload preload preload